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5.0 Extended Features of VSP 

VSP 3.0 has many extended features that have not been described so far in this User’s Guide.  In this 
section, we discuss some key extended features.  The beginning user may not need these features, but a 
more experienced user will find them invaluable.  These features expand on VSP’s core capabilities.  
They are useful once a user has identified a basic sampling design and now wants to explore variations of 
the design, explore features of the design that are not part of the initial selection parameters, and add more 
capability to VSP. 

The extended features fall into three categories: 

• Features found in Main Menu items:  Tools, Options, and View, and 
• Features found in the Dialog Box for individual sampling designs, e.g., the Cost Tab, and the Data 

Analysis Tab 
• Multiple Areas to be Sampled 

5.1 Tools 

5.1.1 Largest Unsampled Spot 

If VSP has generated a sampling design for a Sample Area and you want to know the largest unsampled 
area, VSP can display this information.  The largest unsampled spot is defined as the largest circle that 
will fit inside a Sample Area without overlapping a sample point. 

In Figure 5.1, we opened the VSP Project File Example1.vsp included with the standard VSP installation.  
From the Main Menu we select Tools > Largest Unsampled Spot > Find.  A dialog box tells you that 
VSP will search the Sample Area to find the largest circle that would fit into the unsampled area.  The 
user is given the option of specifying the accuracy of the circle’s radius, whether to consider area corners 
as additional sample points, and whether to allow the spot to overlap the Sample Area.  After hitting the 
OK button, VSP searches the Sample Area, and places the spot on the Map, and displays an Information 
Box that says the radius of this circle is 205.22 ft.  (see Figure 5.2). 

Two other displays are available:  Show Size... and Inside Area....  The Show Size... displays the same 
Information Box shown in Figure 5.2.  Inside Area… brings up the Information Box shown in 
Figure 5.3.  It says that 100% of the circle is within the Sample Area.  If the option to allow the largest 
unsampled spot to overlap the Sample Area edges had been selected, there may be situations where the 
circle extends beyond the boundary of the Sample Area resulting in a percentage less than 100%. 

5.1.2 Reset Sampling Design 

This command clears the current sampling design and removes all samples from the map (including 
unselected sample areas). 
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Figure 5.1.  Largest Unsampled Spot Displayed on Map 

5.1.3 Measure Distance 

Use this tool to measure 
distances on the map.  After 
selecting this command, the 
cursor will become a ruler.  
Click on the map or enter a 
location (x, y) on the keyboard 
to anchor the first point.  A line 
will be drawn from the anchor 
point to the cursor as you move 

the mouse.  The status bar will also indicate the distance from the 
anchor point to the cursor.  After clicking on a second point or entering a second point on the keyboard, a 
dialog will appear displaying the distance.  In Figure 5.4, we see that the distance from the sampling point 
to the building edge is 547.33 ft. 

Hold the Shift key down to attach either point to an existing point on the map. 

 

 

Figure 5.3.  Information Box 
Showing Percentage of Circle 
Within the Sample Area 

Figure 5.2.  Information Box for 
Largest Circle that Would Fit 
Within an Unsampled Area 



September 2004 5.3 Visual Sample Plan Version 3.0 

5.1.4 Make Sample Labels 

Individual samples can have labels and 
values associated with them.  This tool 
lets the user design the sample label.  
Selecting Tools > Make Sample Label 
brings up the Dialog Box shown in 
Figure 5.5.  VSP assumes the user will 
want to assign a unique number to each 
sample within a Map, so all labels start 
with “VSP-<NNN>“.  Other information 
can be added to the label, such as the 
Local X Coordinate and Local Y 
Coordinate as shown in Figure 5.5, by 
selecting the information variable names 
on the list and hitting the Add button.  
(The information can also be added by 
double-clicking on the list item or by 
typing in the label format edit box.).  
Once the OK button is pushed, the user 
sees the current set of Sample Labels in 
Map View. 

Sample labels are discussed in Section 2.4 

5.2 Options 

5.2.1 Random Numbers 

VSP allows the user two options when 
selecting how random numbers are generated.  
The random numbers are used to pick 
coordinates for sampling locations when the 
design calls for either a random-start grid or 
random placement of all points.  The user 
selects the desired random number generator 
using Options > Random Numbers from the 
Main Menu.  The two options are Pseudo-
Random Numbers and Quasi-Random 
Numbers.  The user “toggles” between these 
two options.  This is shown in Figure 5.6.  
Note that once an option is selected, it remains 
active until changed.  VSP is initialized with 
the Pseudo-Random Numbers option active. 

Figure 5.4.  Measuring Tool in VSP 

Figure 5.5.  Dialog Box for Creating Sample 
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Figure 5.6.  Menu for Selecting Type of Random Number Generator 

Sampling locations (i.e., the x and y coordinates of the location) chosen with a pseudo-random number 
generator are not restricted in any way.  The first location chosen and the tenth location chosen can be 
right next to each other or far apart, like throwing darts at a dart board.  The locations where the darts hit 
can be clumped together or spread out, depending on chance. 

Quasi-random numbers are generated in pairs.  One member of the pair is used for the X coordinate; the 
other member is used for the Y coordinate.  The sequence of paired numbers is generated in such a way 
that sample points tend to be spread evenly over a sample area.  VSP’s quasi-random-number generator 
uses Halton’s Sequence.  For a discussion of the algorithms used for both the pseudo- and the quasi-
random number generator, see Version 2.0 Visual Sample Plan (VSP) Models and Code Verification 
(Gilbert et al. 2002). 

If the current sampling design is being added to a study area with existing sampling locations, the quasi--
random number generator will have no knowledge of those locations and might by chance put a new 
sampling location right next to an existing location.  See the Adaptive-Fill option in Section 5.2.2 to 
handle the problem of avoiding existing sampling locations. 

5.2.2 Sample Placement 

The Adaptive-Fill option allows the addition of “random” sampling locations in such a way as to avoid 
existing sampling locations.  Adaptive Fill has to do with the placement of the sampling locations, not the 
number of samples.  The basic idea is to place new sampling locations so as to avoid existing locations 
and still randomly fill the Sample Area.  The current Sampling Design option determines the number of 
locations. 

VSP usually places new sampling locations using the default option, Options > Sample Placement > 
Regular Random.  When Regular Random is selected, the sampling locations produced by either of the 
two random number generators discussed in Section 5.2.1 are placed in the Sample Area without regard to 
pre-existing samples.  In fact, VSP removes all previous sampling locations prior to placing the new set of 
sampling locations. 
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When the Options > Sample Placement > Adaptive-Fill option is selected, all pre-existing sampling 
locations are left in place, and new sampling locations are placed in the Sample Area using an algorithm 
to maximally avoid preexisting sampling locations.  The Adaptive-Fill algorithm can be used with either 
random number generator.  The Adaptive-Fill option is shown in Figure 5.7. 
 

 
 

Figure 5.7.  Adaptive-Fill Option for Sample Placement (Shown Here with Sample Area from Millsite Map) 

Note that in Figure 5.7 the original sampling locations are marked with a circular symbol.  In contrast, the 
Adaptive-Fill sampling locations are marked with a square symbol.  If you right-click on a sampling-
location symbol, a Sample Information dialog will display the type of sample, the coordinates, and a label 
input field.  The label input field allows a specific sampling location to be given an ID number or remark.  
The label information is displayed in the Sample Information dialog, the report view, and the coordinate 
view.  The label is also exported along with other sample information when exported to a text file (see 
Figure 5.9).  See Figure 5.8 for an example of right-clicking on an Adaptive-Fill sampling location. 

If the sampling locations are exported to a text file using Map > Sample Points > Export, an Adaptive-
Fill location will be noted and any label the user might have added will be saved.  An example text file is 
shown in Figure 5.9. 

5.2.3 Graph 

Graphs can be displayed with many different options.  Figure 5.10 shows the options that can be selected 
using Options > Graph.  Options are selected by clicking the option on or off.  Once selected, that option 
will be in place for all Graphs.  Note that we saw these same options in Chapter 4, Figure 4.2a, by right-
clicking on a Graph.  Table 4.2 describes these options in more detail. 
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5.2.4 Measurement Quality Objectives (MQOs) 

The Measurement Quality Objectives (MQO) module in VSP provides a way to extend the sampling 
design to consider not only the number and placement of samples in the field but also what happens in the 
measurement or analysis process.  After all, it is the final result of the “measured sample value” that gets 

reported back to the 
project manager and used 
in statistical tests to make 
a decision. 

There is a trade-off 
between taking more 
samples using a crude 
(i.e., less precise) 
measuring device vs. 
taking fewer samples 
using a precise measuring 
device and/or method.  
This is because total 
decision error is affected 
by the total standard 
deviation of the samples.  
The total standard 
deviation includes both 
sampling variability and 
analytical measurement 
variability. 

There is also a trade-off 
between taking more 

measurements (i.e., replicate measurements) when using these less precise analytical measuring devices 
and/or methods vs. taking few measurements and using more precise analytical measuring devices and/or 
methods.  The MQO module in VSP lets the user play “what-if” games with various combinations of 
sampling standard deviation, analytical (i.e., measurement) standard deviation, number of analyses (i.e., 
replicates) per sample, and number of samples to take.  More discussion of this topic and the sample size 
equations behind the VSP calculations can be found in Version 2.0 Visual Sample Plan (VSP) Models 
and Code Verification (Gilbert et al. 2002). 
 

Figure 5.8.  Sample Information Window Displayed When the User Right-Clicks 
on Selected Sample Points on Map 
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Figure 5.9.  Sample Exported Text File of Sampling Locations 
 

 
 

Figure 5.10.  Graph Options 
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Figure 5.11.  MQO Input Dialog Box with Default Values Displayed 

The MQO option is selected from the dialog that pops up after a Sampling Design has been selected.  The 
MQO option can also be toggled using Options > MQOs from the main menu.  In Figure 5.11, we see a 
dialog box that contains the MQO button (Sampling Goals > Compare Average to Fixed Threshold).  
This dialog box allows you to provide additional inputs, such as the analytical standard deviation and 
number of analyses per sample.  There is also a Pick button (not active at this time but planned in future 
versions of VSP) to provide access to a library of standard analytical methods with their reported 
analytical standard deviations. 

Note that the default values are 0 for the Estimated Analytical Standard Deviation and 1 for the 
Analyses per Sample.  This means that the user-selected analytical or measurement method does not add 
a significant component of variability to the total standard deviation; i.e., the method provides essentially 
the same numeric value when repeated measurements are made on a sample.  Using the input parameter 
values shown in Figure 5.11 and with these default MQO values, we get n = 21 samples. 
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Now let’s start changing the MQO input values.  First, we change the Estimated Analytical Standard 
Deviation to 3.  We still take only one analysis per sample.  We see VSP now tells us we need to take 40 
field samples to obtain the desired error rates we specified.  This is shown in Figure 5.12. 
 

 
 
 Figure 5.12. MQO Input Dialog Box Showing Positive Value for Estimated Analytical Standard 

Deviation with 1 Analysis per Sample 

If we take two repeated measurements of each sample (Analyses per Sample set to 2), we see in 
Figure 5.13 that the number of field samples is now only 31. 

You can try different values in the MQO input boxes and see the effect on the resulting number of field 
samples. 
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 Figure 5.13. MQO Input Dialog Showing Positive Value for Estimated Analytical Standard 
Deviation with Multiple Analyses per Sample 

When you select the COSTS tab at the top of the screen, a new display and set of inputs is shown.  This is 
shown in Figure 5.14.  In this dialog box, we can enter costs for Field Collection (shown here as $100 per 
sample) and Analytical Cost per Analysis (shown here as $400 per analysis).  This screen also provides 
a Cost Comparison between two possible options, Analytical Methods A and B.  We see the Method A 
Analytical Standard Deviation of 3 that we entered on the previous screen.  We can also enter an 
Analytical Standard Deviation for Method B.  Initially, VSP displays the default values of 0 for Method B 
as shown in Figure 5.14.  VSP displays the comparison for one, two, or three replicate analyses for only 
Method A because Method B has an analysis cost of $0.00. 
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Figure 5.14.  Cost Input Dialog Box for MQO Option 

Next we show input values for Method B.  Here, we enter a Method B Analytical Standard Deviation 
of 4 (somewhat higher than Method A), but with a lower Cost per Sample (shown here as $100).  In 
Figure 5.15 we see that the Method Comparison is now filled in with the new values.  The lowest cost 
option (Method B with 1 Analysis per Sample) is highlighted in blue. 

Notice that the lowest cost sampling design for this problem has the most field samples, n = 55.  This is 
because Method B has a very low analysis cost of only $100 vs. the much higher cost for Method A of 
$400.  Therefore, Method B can reduce the uncertainty in the final decision by allowing many more field 
samples to be analyzed compared with Method A. 
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Figure 5.15.  Display of Cost Comparison for Method A and Method B from MQO Module 

Note also that the sampling design will not automatically change to the Method B case highlighted in 
blue.  If you want a sampling design based on Method B, you must update the Analytical Cost per 
Analysis for Method A to match the Method B cost.  Then return to the One-Sample t-Test tab, change 
the Estimated Analytical Standard Deviation value to match the Method B value, and press the Apply 
button to get the Method B-based sampling design. 

A graphical comparison of the analytical methods is shown on the Decision Performance Curve when 
Options > Graph > MQO Method Comparison is checked.  You must go to View > Graph to see the 
chart.  Figure 5.16 shows an example. 

The yellow circle is placed above the lowest-cost sampling design that meets the objectives.  In this case, 
the circle is above a green bar representing the cost of using sampling design Method B with one analysis 
per sample. 
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5.2.5 Sensitivity Analysis 

This option accesses the sensitivity analysis 
parameters on the Report View.  The 
sensitivity analysis parameters may also be 
accessed by right-clicking on the Report View 
itself.  The example shown in Figure 5.17 is 
from the VSP Project File Example1.vps.  With 
View > Report selected, scroll down to the 
section on Sensitivity Analysis.  Now select 
Options > Sensitivity Analysis, and the Dialog 
Box shown in Figure 5.17 is displayed.  The 
user can do sensitivity analysis on up to 
4 variables (only 3 are shown here), can select 
a starting and ending value for each variable, 
and can specify the number of steps for 
incrementing the variable.  VSP displays the 
values for each step in Red below the Step 
window.  For this example, in Figure 5.17, we 
say we want to see the number of samples 
required at values of the Standard Deviation s= 

1.2, and 0.6.  For each of these levels, we want to look at three levels of Beta, and three levels of Alpha.  
VSP calculates sample size for each of these 2 x 3 x 3 = 18 options and displays the values in the table. 

This option is a very powerful tool for looking at “what if” scenarios and determining trade-offs for risk 
and cost.  Tables for Number of Samples, Sampling Cost, or both can be displayed.  Figure 5.18 shows 4 
of the DQO Parameters being changed, and shows the results of the sensitivity analysis for both number 
of samples and cost. 

5.2.6 Preferences 

Figure 5.19 shows the Preferences available in VSP.  Table 5.1 provides a brief description of each 
Preference.  Consult VSP Help > Help Topics > Menus > Options menu > Preferences for a more 
detail discussion of each menu item. 

5.3 View Menu 

The View Menu offers the user options for how VSP displays information.  Table 5.2 gives a brief 
description of each option.  Consult VSP Help > Help Topics > Menus > View menu for a more detail 
discussion of each menu item.  Many of these items have been discussed previously in this manual and 
will be mentioned only briefly here. 

Figure 5.16.  MQO Method Comparison Chart 
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 Figure 5.17. Sensitivity Analysis for 3 DQO Input Parameters.  Results are shown for Number of 

Samples, as displayed in a table in Report View. 
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 Figure 5.18. Sensitivity Analysis for 4 DQO Input Parameters.  Results are shown for Number of 

Samples and Cost, as Display in a Table in Report View 
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Table 5.1.  Preferences Menu Items 
 

Input Delta Allows the input of Delta in design dialog boxes 
Input LBGR / UBGR Allows the input of LBGR / UBGR in design dialog boxes. 

 
Version Changes the sub-version of VSP (which eliminates some of the 

sampling design choices) 
Initial Information Displays the initial information associated with the chosen sub-

version of VSP. 
 

Judgment Sampling Information Displays informational dialog when judgment sampling is used. 
 

Table 5.2.  View Menu Items 
 
Main Toolbar Shows or hides the main toolbar 
Map Drawing Toolbar Shows or hides the toolbar used for drawing on maps. 
Ranked Set Toolbar Shows or hides the toolbar used for ranked set sampling 
Room Toolbar Shows or hides the toolbar used for room manipulation 
Status Bar Shows or hides the status bar. 
Labels Shows or hides the sample labels on the map.  Any combination of 

Labels, Coordinates, Local Coordinates and Values can be 
displayed. 

Background Picture Shows or hides the background picture. 
Transparent Sample Area Allow background picture to be seen behind sample areas. 
Largest Unsampled Spots Shows or hides the largest unsampled spots. 
All Grid Cells Shows or hides all grid cells used for adaptive cluster sampling 
Leading Edge Shows only the leading edge of an open-type sample area 
Map Scale Shows or hides the coordinate scale on the map. 
Map Legend Shows or hides the map size legend. 
Swath Corners Shows the coordinates at the corners of swaths 
Room North Arrow Shows or hides the north arrow in the room view. 
Room Perspective Ceiling Shows or hides the ceiling in the perspective room view. 
Map Change current project view to map view. 
Graph Change current project view to graph view. 
Report Change current project view to report view. 
Coordinates Change current project view to coordinate view. 
Room Change current project view to room view. 
Zoom In Increase the map view size. 
Zoom Out Decrease the map view size. 
Zoom Max Change map view size to fit window 
Zoom Window Increase map view size to selected area. 

 
Pan Move the visible portion of the map. 
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5.4 The Cost Tab:  Setting Up Sampling Costs – Inputs for the General 
Screen 

VSP allows users to enter sampling costs so that the total cost of a sampling program is available.  Once a 
sampling design is selected and the DQO inputs have been entered into one of the dialog boxes, click on 
the Costs tab to enter costs.  A sample Costs screen is shown in Figure 5.20.  The inputs for this example 

were entered in the Dialog Box 
shown in Figure 5.21. 

VSP enables you to break down 
costs into the following 
categories: 
 
• fixed planning and validation 

costs - This is the fixed cost 
that is incurred, regardless of 
how many samples are taken.  
Examples of fixed costs are 
the cost to mobilize a 
sampling crew and get the 
equipment into the field. 

• field collection cost per 
sample - This is the per-

sample Figure 5.22.  Screen for Entering cost.  Examples of per-unit field costs are the costs paid to 
Sampling Costs for Sampling Design technicians to collect the sample and package and transport it. 

• analytical cost per analysis - This is the cost to analyze a specimen or a sample.  As discussed in 
Section 5.4, you can specify how many repeated analyses you want taken per sample or specimen. 

VSP calculates a total cost for the design specified, shown here as $11,500.  Total cost is the sum of the 
fixed cost, shown here as $1,000, plus per-sample field collection cost of $100, plus analytical cost per 
analysis of $400, multiplied by the number of samples, 21.  No duplicate analyses were specified, so the 
total per-unit cost is $500.  Thus, the total sampling cost is $1000 + 21 x $500 = $11,500. 

The hot spot sampling goal has some unique cost features.  First, costs are displayed in one of the tables 
in the Report View and not on the Cost tab of the dialog box.  Second, this is the only Sampling Goal for 
which you can specify a cost as a design criteria and VSP will calculate the number of samples to meet 
that goal (see Section 3.2.8).  This is done by selecting from the main menu Sampling Goal > Locating a 
Hot Spot > Systematic Grid Sampling > Predetermined fixed cost. 

5.5 Multiple Areas To Be Sampled 

VSP allows the user to select multiple areas as sampling areas.  All the examples shown so far involved a 
single Sample Area.  When multiple areas are selected, VSP allocates the samples to the areas in 

Figure 5.20.  Screen for Entering Sampling Costs for a Sampling 
Design – Accessed through the Cost Tab 
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proportion to the area of the respective individual sample areas.  For example, if one area is twice as large 
as the other sample area, it will receive twice as many sample points.  This is shown in Figure 5.23. 
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In Figure 5.23, we show two sample areas -- a rectangle and a circle.  We next assume that a sampling-
design algorithm not currently in VSP called for n = 25 samples.  Using option Sampling Goals > Non-
statistical sampling approach > Predetermined number of samples > Simple random sampling, VSP 
allocated 7 of the 25 requested samples to the rectangle and 18 to the circle.  This is because the circle 
covers an area approximately three times larger than the rectangle. 

Note that when multiple sample areas are drawn on a Map, you can select or deselect sample areas using 
Main Menu option Edit > Sample Areas > Select/Deselect Sample Areas.  Alternatively, you can select or 
deselect a sample area by clicking on it with the mouse. 

The Change Color option can be used to change a sample area’s color.  First, select those sample areas to 
be given a new color.  Then use the Edit > Sample Areas > Change Color sequence and choose the new 
color for the currently selected sample areas. 
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Note that when multiple sample areas are selected, VSP-derived sampling requirements assume that the 
decision criteria and summary statistic of interest (mean, median) apply to the combined sample areas and 
not to the individual areas. 

 
 

Figure 5.23.  Proportional Allocation of Samples to Multiple Sample Areas 


